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Parallax Servo Controller – USB (#28823) Rev B
16-Channel Servo Control with a USB Interface

Introduction

With the proliferation of servos used in technology today comes the obligation to manage multiple servos 
each executing complex motions.  The original Parallax Servo Controller (#28023) was designed to 
remove the burden of driving the servo pulses from the controller and thereby expand the number of 
servos that one controller could be expected to control.  To that end the original PSC was quite 
successful, but for some of the more complex applications writing a textual program to control many 
servos executing compounded motions and actions can be tedious to say the least.

One way to make the whole application development process easier is to change the primary interface 
from a keyboard (text-based code) to that of a mouse (visual based program).  By adding a USB port to 
the servo controller and providing the user with a free graphical user interface, a direct link between 
mouse and servo is made.  Move the mouse, the servo moves in real-time.  Now the task of developing a 
program to control intricate servo sequences becomes a palatable fun process.

The concept of the frame is introduced to help keep movements and sequences organized and 
manageable.  Sixteen servo positions and time delays make up a frame; two or more frames constitute a 
sequence.  Sequences may be stored as files on your PC’s hard drive to be retrieved for later use, or you 
may optionally download your sequence into a stamp (BS2 or larger).  Like a movie, a sequence may be 
played, paused, stopped, or edited repeatedly until you get it just the way you want it.

With animatronics customers in mind, the current PSCI software supports up to 128 frames.  (Most 
animal walking sequences require fewer than 8 frames.)  Subsequent releases of the PSCI software will 
support more frames, so check our website periodically for updates.  Optional loop commands can cause 
the sequence to repeat part or all of itself any where in the sequence.  The latest version of the Parallax 
Servo Controller Interface software, (PSCI) is always available free from our website.

Packing List

Verify that your Parallax Servo Controller is complete in accordance with the list below:

�x Parallax Servo Controller – USB (PSCusb)
�x Shunt-Jumper
�x 3-Conductor Cable
�x A to mini-B USB cable
�x Documentation (this manual)
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Features

�x Each Servo is individually controllable: Position, rate, offset, and post delay.
�x Speed Control. Each servo may have any of 63 run-time changeable rates.
�x 128 Frames supported though most sequences require far fewer frames.
�x Looping enables sequences to repeat entirely or just parts.

Before You Begin

The processor used on the PSCusb requires 5 VDC which is supplied by the USB port.  Servos 
require far more power than the USB port can supply.  Therefore you must use a separate 
power supply for your servos. In general, servos require 4-7.5 VDC.  Be sure that the servo 
power source can supply ample current at the proper voltage and will not damage the 
servos. 

Getting Started

Locate and remove the PSCusb from its protective anti-static bag.  It should closely resemble the image 
shown in Figure 1 .

Figure 1: PSCusb – Rev B and mounting-hole detail

Mount the PSCusb using 4-40 screws (or equivalent).  Ensure that none of the connections on the pcb 
bottom are inadvertently shorted.
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Ensure the servo power switch on the Parallax Servo Controller is off, and then connect the power source 
for the servos to the screw terminals observing proper polarity.  Servos require more power than the USB 
port can supply.  For this reason, you must connect a separate power supply for the servos.  See figure 
2.

Figure 2: PSCusb, typical Connections.
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* Note: Though a Rev A board is depicted here, the connections for the Rev B board are exactly the same.

Installing the PSCI software

Visit us at www.parallax.com and search for 28823.  The download icon should be near the product 
image.  Once the program is downloaded, double-click on it and follow the installation instructions.
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Using the PSCI software

Once installed, launch the PSCI software.  It should start immediately and the following screen will be 
displayed: 

  

USB Drivers

The USB chip used by the PSCusb requires you to install drivers on your PC before using it.  These drivers 
are the same ones required by the Board of Education (with USB interface), so if you have already 
installed these drivers, you needn’t repeat this procedure.  The drivers are free and available from 
www.ftdichip.com.  Simply go to their website and click on the “Drivers” button.  From the list of FTDI 
chips provided, select the FT232BM entry.  Under the Driver Package heading, select the file that 
corresponds to your operating system and save this file to your desktop.

After downloading has completed, close your web browser and double click on the driver file you just 
downloaded to start the installation process.  Follow the prompts as directed.  If you have any difficulty, 
simply call Parallax Tech Support tool-free at (888) 99-STAMP, [888-997-8267].  Now you are ready to 
use your new hardware.
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Selecting the USB Port

Unlike serial ports, USB ports are dynamic.  That is to say that they are manifested when the PSCusb is 
connected, and extinguish themselves upon disconnecting.  If you are so inclined to witness this 
phenomenon, simply open up the properties of the My Computer icon, then click on the Hardware tab, 
then click on the Device Manage button.  Once in the Device Manager, click on the small + sign next to 
the Ports icon.  Now, connect and disconnect the PSCusb while watching the Ports list.  For proper 
operation, connect your PSCusb to the PC USB port before  launching the PSCI software.

To select a comm port, simply click on the File tab and hover the mouse over the Select Comm Port entry 
to invoke the list of found comm ports.  To choose a comm port, simply click on that comm port.  If all 
goes well, a message will report the successful opening of the comm port.  
If you wish to confirm the presence of the PSCusb, you may then click on File->Get PSC version.  If the 
PSCusb is found, the version number will appear in the message window on the left side of the PSCI 
screen.  See below.



Parallax, Inc.  •  Parallax Servo Controller – USB Rev B ver 3.3 (#28823) • 5/20056

Controls Description

To control the servos in real-time mode, connect your servos to the PSCusb and simply slide the power 
switch on the PSCusb to the ON position.  Now, moving the corresponding servo position slide bar in the 
PSCI software positions the servo.

Offset

Not all servos are alike so the offset control allows you to vary the center point of each servo.  This may 
not matter too much for standard servos, but is very helpful when controlling servos modified to rotate 
360 degrees.

Position

You may use either the slide control or the up/down arrows, or enter the servo position numerically to set 
the servo position.  Please note that by clicking on the numbers 2500, 1500, or 750, the servo position 
will be set to that number.  These numbers correspond to the width of the servo command pulse, in 
microseconds.

Rate

Each servo may be set to a rate of rotation.  Furthermore, each servo may have a different speed for 
each frame.  A servo rate of 0 will cause the servo to move as quickly as possible; it’s fastest rate.  A 
servo position of 63 will cause the servo to move to it’s destination position at its slowest rate.  At speed 
63, the servo takes about 45 seconds to complete a 180 degree motion.

Delay

When a frame is executed, as in animate mode, a servo command is sent to the PSCusb for each servo in 
the order 0,1,2,3…  After each servo command is sent, the delay time is observed before sending the 
next servo command.  The Delay parameter has no effect when operating in real-time mode.

Frame

The number to the right of the word “Frame” indicates the current frame.

Go to

The number to the right of the phrase “Go to” shows the frame number that will be jumped to when all 
servo commands have been sent and all delays have been observed for the current frame.  Note: no 
servo commands are sent for servos that appear to be unused.

Animation Controls

Controls are provided to facilitate the creation, controlling, and editing of animation sequences.  By 
hovering the mouse over each control button (without clicking) a hint will pop up to help clarify the 
purpose of the button.  Additional information is available by clicking on Help->Help in the PSCI software.
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Creating a Sequence

Creating a sequences is easy.  The following example shows you how to create a simple sequence.
Click on the 500 position for servo channel 0 and edit the delay for that channel to 500mS as shown.

Click the red circle (Record) to record the frame.  Note: clicking the record button on the last frame of a 
sequence caused the current frame to be copied to the next frame (this helps with animation sequences).  
If you were to click the record button after editing an existing frame, the current frame would be 
updated, and the next frame would not be disturbed.  

Click the number 2500 for channel 0 and click the record button again.  
Click the number 500 for channel 0 and click the record button again.
Click the number 1500 for channel 0, increment the Go to number to 0 and click the record button.

That completes one simple animation sequence.  Now you may use the CD-like control buttons to run, 
stop, and pause your animation sequence.

To save your sequence, simply click on Sequence->Save and specify a file name.
To retrieve your saved sequence, simply click on Sequence->Open and specify the filename.
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Download – Theory of Operation

Once the sequence has been written, debugged, and honed to work as desired, one may wish to not be 
limited to having a PC execute the sequence.  If this is the case, the download button is for you.  By 
clicking the download button, you invoke the PSCI to send its commands, delays included, to the BASIC 
Stamp® instead of the PSCusb.

This is achieved with an augmented header that the PSCusb ignores thereby passing these serial 
messages to the stamp.  The stamp is connected via a three pin cable to the PSCusb.  Once downloaded, 
the stamp executes your sequences just as the PSCI software did.

Though the download button functions, the stamp program has not been written at this time to receive, 
store, and parse the data.  Fear not, we will be posting that program to our website very soon.

Notes concerning the connection of the PSCusb to your stamp.

To those individuals using the Board of Education, Rev C: 
1) The power source for the servos must be a separate power source from that of the 

Board of Education.
2) Connect the three-pin cable from the PSCusb to X4, slot 15.  
3) Ensure that the Vservo jumper selector, (between X4 and X5), is set to the VDD 

position.  Connect your servos to the 3 pin terminals provided.
4) To power your PSCusb, the power switch must be placed to the “2” position.

To all other users:
1) The power source for the servos must be a separate power source from that of the 

5 VDC used to supply the on-board logic.
2) Connect the three pin cable from the PSCusb to: VDD (Red), VSS (Black), and the 

white wire to your choice of I/O pin.  VDD must be 5 VDC.  Note: the idle state of 
the serial line is 5 VDC.

Hardware Reset Pushbutton

The pushbutton on the PSCusb is connected to the reset circuit of the on-board microcontroller.  Pushing
this pushbutton resets the microcontroller thereby resetting all parameters to their default values. 
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Revision List

Hardware Firmware
--------------------------------------------------------------------------------------------------------------------------------

Rev A 1.4 (Internal prototype, never released)

No known issues with this version of firmware.  Though the PSC – Serial was released with earlier version 
of firmware, the PSCusb was only released with v1.4 firmware.

--------------------------------------------------------------------------------------------------------------------------------

Rev B 1.4 (Initial release)

No known issues with this version of firmware.  Though the PSC – Serial was released with earlier 
versions of firmware, the PSCusb was only released with v1.4 firmware.

--------------------------------------------------------------------------------------------------------------------------------

Note: your PSCusb is re-programmable.   If your PSCusb firmware is not current, you may send it in to 
Parallax for a free firmware upgrade.  Your only cost is the shipping fee.

Liability Disclaimer

Parallax, Inc. is not responsible for special, incidental, or consequential damages resulting from any 
breach of warranty, or under any legal theory, including lost profits, downtime, goodwill, damage to or 
replacement of equipment or property, and any costs of recovering, reprogramming, or reproducing any 
data stored in or used with Parallax products.


